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Bone geometry is commonly measured on computed tomographic (CT) and X-ray microtomographic (μCT)
images. We obtained hundreds of CT, μCT and synchrotron μCT images of bones from diverse species that
needed to be analysed remote from scanning hardware, but found that available software solutions were
expensive, inflexible or methodologically opaque. We implemented standard bone measurements in a novel
ImageJ plugin, BoneJ, with which we analysed trabecular bone, whole bones and osteocyte lacunae. BoneJ is
open source and free for anyone to download, use, modify and distribute.
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Introduction

Bones are commonly imaged in computed tomographic (CT) and
X-ray microtomographic (μCT) systems for research purposes, such as
investigating trabecular and cortical changes in osteoporosis [1,2],
comparative anatomy [3,4], and non-destructive examination of fossil
skeletons [5,6]. We had hundreds of CT, μCT and synchrotron μCT scans
of whole bones and trabecular bone cubes to analyse for studies on
allometric bone scaling [7,8] and osteogenesis imperfecta. Many of our
scans were over 1 GB, but we found existing software could not process
large (N60 MB) datasets, required a per-machine licence fee, or did not
implement all of our required features.Weneeded to open varied image
formats from diverse instruments, then pre-process, analyse and
visualise scans efficiently on several different computers, remote from
scanning hardware.We took advantage of the existing functionality and
flexible plugin architecture of the public domain image processing
program ImageJ [9] and implemented standard bone measurements
[10–15] as an ImageJ plugin, BoneJ [16], tomake full use of our computer
hardware. This technical notedescribes thephilosophyandvalidation of
BoneJ, and illustrates its application with use case scenarios.

Materials and methods

Approach

We first incorporatedwell-defined parametersmeasured by the bone
research community, using definitions in primary references and
standardised nomenclature (Table 1). Model-independent methods
were preferred over techniques that make assumptions of underlying
geometry [10]. Stereological techniques that assume rod- or plate-like
trabecular structure were avoided where a good alternative existed
[11,17]. For trabeculae, three-dimensional (3D) methods were used
exclusively [12]. Cross-sectional diaphyseal parameters such as second
moment of area and section modulus were calculated directly from pixel
positions without assuming circular or elliptical geometry. Where
possible, users were given the choice between voxel-based methods, in
which the image is treated as a 3D grid of points, and mesh-based
methods, in which interconnected triangles are overlaid on the 3D grid to
approximate the bone surface.
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Table 1
Summary of current BoneJ commands. See the User Guide at http://bonej.org/ for
detailed and up-to-date explanations of all commands.

Command Summary

For trabeculae
Analyse Skeleton Calculates branch length and counts junctions [22]
Anisotropy Estimates degree of anisotropy (DA) using the mean

intercept length [13]
Connectivity Uses the Euler characteristic to calculate connectivity

density (Conn.D) [23,24]
Fractal Dimension Estimates the fractal dimension (FD) with the box

counting method [25]
Isosurface Measures bone surface area (BS) and displays the

surface in 3D
Optimise Threshold Set a threshold from image stack histogram that

minimises Conn.D [29,30]
Plateness An experimental replacement for SMI, ellipsoid axes

conceptually similar to [26]
Purify Prepares an image for connectivity analysis by removing

small particles [23]
Skeletonise 3D Erodes an image to its medial axis, preparing it for

skeleton analysis [27]
Structure Model Index Calculates the structure model index (SMI) [14]
Thickness Measures trabecular thickness (Tb.Th) and spacing

(Tb.Sp) [10,28]
Volume Fraction Measures volume fraction of bone (BV/TV) [15]

For whole bones
Fit Ellipsoid Fits an ellipsoid to points placed on a structure, e.g.

a femoral condyle
Fit Sphere Fits a sphere to points placed on a structure, e.g. a

femoral head
Moments of Inertia Finds the moments of inertia and aligns a bone to

the principal axes [18]
Neck shaft angle Measures the femoral neck shaft angle in a 3D dataset
Slice Geometry Measures cross-sectional parameters (cortical thickness,

area, section modulus) [18,31]

For osteocyte lacunae
Particle Analyser Locates by label propagation and analyses particles

(e.g. osteocyte lacunae) in 3D [20]

1 Plugins→BoneJ→Connectivity formatting indicates menu selections from ImageJ's
graphical user interface.
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Validation

Algorithms in BoneJ were validated by running them on test data
and comparing computed results to expected results. Test data
included synthetic images, images of real objects and mathematically
defined clouds of points (Fit Sphere and Fit Ellipsoid), all with known
geometry. Analyse Skeleton was tested against a set of branching
structures, loops and points. Anisotropy was tested on stacks
containing Gaussian noise (isotropy) or parallel plates (anisotropy).
Connectivity was validated by creating simple connected structures
and measuring their Euler characteristics. Fractal Dimension was run
on images from ImageJ's Fractal Generator plugin, for which
theoretical fractal dimensions were known. Isosurface was tested on
images of cubes and spheres. Optimise Threshold was tested on μCT
images of trabecular bone. Plateness, which calculates ratios of
ellipsoidal axes of summed star volumes fitting within a structure,
was tested on synthetic images containing rod-like, plate-like or
spherical structures. Purify was validated on images where the largest
particle was known. Subtracting the purified result from the original
image highlighted deleted particles and cavities. Skeletonise 3D was
tested on synthetic images of branching and looped structures and
μCT images of trabecular bone. Structure model index was tested on
synthetic images of plates (SMI=0), rods (SMI=3) and spheres
(SMI=4). Thickness was tested on images of single, circular rods with
known diameter and length several hundred times diameter. Volume
Fraction was tested on binary images with known proportions of
voxels set to foreground and background. Moments of Inertia was
tested on images of cylindrical and rectangular beams, with known
width and height, and compared against standard equations from
classical mechanics [18]. Neck Shaft Angle, the angle between vectors
defining the femoral diaphysis and femoral neck projected on the
plane containing the diaphyseal vector and centre of the femoral head,
was tested on CT images of femora, and compared to measurements
on the real bones. Slice Geometry was validated against synthetic
images of elliptical rings representing diaphyseal cross-sections, with
results compared to theory [18,19]. Particle Analyser was tested on
synthetic images with known particle distribution to confirm correct
particle labelling and measurement. The same 1 cm3 cube of
trabecular bone from the femoral head of an Asian elephant (Elephas
maximus) was sent to both Scanco (Brüttisellen, Switzerland) and
SkyScan (Aartselaar, Belgium) for independent scanning and analysis;
images returned by SkyScan were measured in BoneJ.

Results

Development resulted in a collection of menu commands that
were used to collect experimental data ([7,8] Table 1). Processing
steps were recorded with ImageJ's macro recorder (Plugins→Ma-
cros→Record1), so that a whole directory of images could be mea-
sured in batch mode. A selection of processing steps that illustrate
typical usage scenarios follows. For detailed treatment of each
command, we refer the reader to the User Guide online at http://
bonej.org, which is kept up-to-date with code changes in BoneJ. Some
familiarity with ImageJ is assumed for readers following these
examples; documentation is readily available for its use in book
form and on the internet [9,20,21].

Typical use cases

Use Case 1: measuring trabecular parameters in a 3D μCT scan
Open scan as a virtual stack by dragging and dropping directory of

scan slices onto ImageJ. Crop empty slices above and below cube with
Plugins→Stacks→Delete Slice Range. Crop sides with ImageJ's rect-
angular region of interest (ROI) tool and Image→Crop command.
Automatically segment into bone and background with Plugins→Bo-
neJ→Optimise Threshold (Threshold only; Apply threshold). Measure
bone volume fraction (BV/TV) with Plugins→BoneJ→Volume Frac-
tion. Measure trabecular thickness (Tb.Th, Fig. 1A) and spacing (Tb.Sp)
with Plugins→BoneJ→Thickness. Measure degree of anisotropy (DA)
with Plugins→BoneJ→Anisotropy. Measure connectivity density
(Conn.D) with Plugins→BoneJ→Connectivity. All data are appended
to a single row of the results table, labelled with the image's file name.

Use Case 2: measuring cross-sectional parameters in a CT scan of a
whole bone

Open a CT scan by dragging the containing directory onto ImageJ.
Align the bone to its principal axes with Plugins→BoneJ→Moments of
Inertia. Select the slice to measure by scrolling through the stack and
run Plugins→BoneJ→Slice Geometry. Cross-sectional parameters like
cortical thickness, cross-sectional area, centroid, principal axes,
second moment of area (I) and section modulus (Z) are measured
from pixel coordinates, without any assumption of cross-sectional
geometry (Fig. 1B). Either a single slice or all slices in the stack can be
measured.

Use Case 3: measuring osteocyte lacunae in synchrotron μCT images of
bone

Open a μCT scan by dragging the containing directory onto ImageJ.
Crop the stack to contain only particles of interest by drawing a rectangle
ROI and running Image→Crop. Set a threshold that renders cavities as
foreground with Image→Adjust→Threshold, and binarise the stack
(Apply). Analyse osteocyte lacunae by running Plugins→Analyze→

http://bonej.org
http://bonej.org
http://bonej.org/


Fig. 1. Graphical output from BoneJ. (A) Trabecular thickness (Tb.Th) measured with the Thickness command. Yellow regions are thicker than blue regions. (B) Centroid and
principal axes as calculated by Slice Geometry on a tomographic slice from the tarsometatarsal bone of a little spotted kiwi (Apteryx owenii). (C) Murine osteocyte lacunae imaged
with synchrotron μCT and measured with Analyse Particles.
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Analyse Particles, selecting desired output such as surface area, vol-
ume and orientation, and optionally visualise osteocyte lacunae in 3D
(Fig. 1C).
Validation

Fit Sphere and Fit Ellipsoid created highly accurate fits to test data,
with errorsb0.01% for centroid and radii measurements. Skeletonise 3D
and Analyse Skeleton correctly identified branches in simple rod-like
structural networks but their medial axis erosion model did not
accurately represent plate-like structures. Anisotropy gave correct
results for both isotropic (DA=0.008–0.010) and anisotropic
(DA=1.000) test images. Fractal Dimension correctly calculated FD of
fractal images,within the limit of pixel size. OptimiseThreshold resulted
in subjectively acceptable thresholds; its main advantage over manual
thresholding is that it can run without user intervention during batch
processing. Plateness (experimental) identified plate-like, rod-like and
spherical structures by their expected ellipsoidal axis ratios, but a
meaningful summary variable for this architectural feature of bone is
elusive. Isosurface calculated the surface area of spheres and cubes with
0.1–0.3% error. Structure Model Index gave results close to expected
(plate SMI=0.044; rod SMI=3.175; sphere SMI = 3.999). Thickness
error was less than a single voxel width for Tb.Th and Tb.Sp. Particle
labelling was extremely reliable, correctly identifying and joining all
particles, while Purify, based on Particle Analyser, always retained the
largest particle and filled small cavities. Connectivity calculated the
Euler characteristic without fault and was insensitive to hole position
and feature size. Volume Fraction calculated exact results when used in
voxel mode, but in surface mode when smoothing was high (6 voxels),
slight deviation from true (~1.5%) was observed. BoneJ's trabecular
statistics were similar to those calculated with commercial software
(Table 2). Slice Geometry and Moments of Inertia calculated exact
results when cross-sections were rectangular, but due to pixel alias
artefacts, curved shapes and rotated rectangles resulted in slight (~1%,
depending on size) deviation from theory. Errors in Neck Shaft Angle's
results (1.6–15.9%) were strongly influenced by the operator's experi-
ence in identifying the femoral neck in CT scans.
Table 2
Common trabecular bone parameters measured with commercial software and BoneJ.
The same bone cube was sent to SkyScan and Scanco for scanning and analysis;
SkyScan's images were analysed in BoneJ.

Software BV/TV Tb.Th (mm) Tb.Sp
(mm)

BS/TV
(mm−1)

Conn.D
(mm−3)

DA

SkyScan CTAn 0.447 0.400 0.695 3.438 2.127 0.534
Scanco 0.421 0.440 0.839 2.454 2.325 0.381
BoneJ 0.448 0.433 0.729 2.944 1.902 0.541
Discussion

BoneJ presents several advantages to users of bone morphometry
software. It integrates with ImageJ's diverse plugin ecosystem, so a
customisable series of processes can be performed to get experimen-
tal results from a wide range of image file formats without switching
between programs or platforms. Furthermore, a sequence of image
processing steps can be automated with a macro and applied to a
batch of images, improving workflow by reducing time spent
manually executing commands. BoneJ is primarily designed to
measure bone geometry, but the parameters are not limited to bone
and can be generalised to many foams, beams and particles or pores,
as are found in food, engineering materials, biological structures and
soil. Unlike commercial programs, BoneJ is available free of charge, so
limited research funds can be redirected from software licensing to
staff and hardware. BoneJ is also independent of scanner hardware, so
it can be obtained without purchasing a scanner and can be used in a
different location to the imaging device, which may be sited in a
hospital, a collaborator's laboratory or a synchrotron facility.

BoneJ is written in the Java programming language [20,32,33], so
wherever there is a Java runtime environment (JRE), ImageJ and BoneJ
can be used. JRE's are commonly installed on Microsoft Windows,
Unix and Unix-like operating systems (including Apple Mac OS X and
GNU/Linux), making BoneJ independent of the underlying operating
system and system hardware. BoneJ uses Java's multithreading ability
in Thickness, Anisotropy, Moments of Inertia, Analyse Particles and
other plugins. Multithreading splits jobs into smaller chunks, which
are processed independently to accelerate job completion, and takes
advantage of consumer-level computers being equipped with in-
creasing numbers of processing cores. If the hardware, operating
system and JRE are 64-bit, the maximum image size that can be
processed by BoneJ is limited only by installed physical memory. On
our 64-bit systems, we process image stacks in excess of 4 GB, greater
than the total addressable memory of a 32-bit system. BoneJ makes
use of the ImageJ 3D Viewer [34], which provides hardware-
accelerated visualisation of 3D and 4D (3D×time) multichannel
data. BoneJ will run on most contemporary computers, but to process
and visualise large datasets we recommend running it on a 64-bit
system with as much RAM and as many CPU cores as possible, and
with a hardware-accelerated graphics adapter.

The freedom of the open source development model allows truly
open access to methodological details because all of the calculations
are provided in source code form with the program. Open access to
methods neatly complements many journals' requirement for open
access to data and further lowers the barrier to replication of studies.
BoneJ's development is mainly funded by governmental research
grants, so it is propagated broadly to create the greatest public good.
Code changes are tracked with Git version control [35] which
facilitates code development at multiple, distributed sites, allowing
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BoneJ to be independent of a single author, institute or company.
Developers are welcome to make improvements to their own
branches of BoneJ, and are encouraged to submit them back to MD's
master branch for everybody's use. All development changes on the
master branch are public and easily browsable by anyone [36]. While
every effort is made to ensure reliable operation, as in other scientific
methods the onus of validating individual results lies with the person
carrying out the experiment.

Conclusions

BoneJ is available for everyone to download, use, modify and
distribute at no cost. It calculates several trabecular, cross-sectional
and particulate parameters in a convenient format. Care has been
taken to ensure measurements are standardised, so that results are
comparable between studies. Java technology allows BoneJ to run on
commodity computers, independent of scanner devices, fully utilising
hardware resources. ImageJ's plugin infrastructure provides a flexible
working environment that can be tailored to diverse experimental
setups. BoneJ is a working program and a starting point for further
development, which will be directed by users' requests and the
emergence of new techniques.
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